• <s id="fgxn9"><samp id="fgxn9"><listing id="fgxn9"></listing></samp></s><ruby id="fgxn9"><table id="fgxn9"></table></ruby>
    <dd id="fgxn9"></dd>
    <dd id="fgxn9"><center id="fgxn9"><video id="fgxn9"></video></center></dd>
      <th id="fgxn9"></th>
    1. <li id="fgxn9"><object id="fgxn9"><cite id="fgxn9"></cite></object></li>
      <span id="fgxn9"></span>
    2. <dd id="fgxn9"><track id="fgxn9"></track></dd>

            <span id="fgxn9"></span>

            <button id="fgxn9"></button>

            <tbody id="fgxn9"><p id="fgxn9"></p></tbody>

            1. <tbody id="fgxn9"><track id="fgxn9"><i id="fgxn9"></i></track></tbody>

              <dd id="fgxn9"></dd>

              <th id="fgxn9"></th>
              <button id="fgxn9"><object id="fgxn9"></object></button>
              <th id="fgxn9"></th>

              <rp id="fgxn9"></rp>
              ?
              打開微信“掃一掃”,開啟安全數字世界之旅
              截圖或長按保存至相冊,使用微信掃一掃
              首頁 > 安全通告

              安全通告

              極危!XZ Utils 5.6.0/5.6.1版本惡意后門植入漏洞風險通告
              發布時間 :2024年03月31日
              分享:

              今日,亞信安全CERT監控到安全社區發布安全通告,披露XZ Utils 5.6.0、5.6.1版本存在惡意后門植入漏洞(CVE-2024-3094)。開發人員在調查SSH性能問題時發現了涉及XZ Utils的供應鏈攻擊。從 5.6.0 版開始,在 xz 的上游liblzma庫中發現了惡意代碼。通過一系列復雜的混淆處理,liblzma 編譯過程從源代碼中存在的偽裝測試文件中提取了一個預編譯對象文件,然后用來修改 liblzma 代碼中的特定函數。這樣就產生了一個經過修改的 liblzma 庫,任何與該庫鏈接的軟件都可以使用它,攔截并修改與該庫交互的數據。攻擊者可能利用這一漏洞在受影響的系統上繞過SSH的認證獲得未授權訪問權限,執行任意代碼。


              已知XZ Utils 版本5.6.0和5.6.1受到影響,惡意代碼還不存在于XZ的Git發行版中,僅存在于完整的下載包中。已知的Linux 發行版包括Fedora Rawhide、Fedora 41、Debian非穩定的測試版 5.5.1alpha-0.1 到 5.6.1-1等。亞信安全CERT建議使用受影響版本的用戶及時關注官方消息,請立即停止使用 Fedora 41 或 Fedora Rawhide ,以及相關測試版Debian,使用了受影響版本的XZ Util ,建議降級至 5.6.0 以下版本,或在應用中替換為7zip等組件,在應用中替換為7zip等組件做好資產自查以及預防工作, 以免遭受黑客攻擊。


              xz 是一種通用數據壓縮格式,幾乎存在于所有 Linux 發行版中,包括社區項目和商業產品發行版。從本質上講,它有助于將大型文件格式壓縮(然后解壓縮)成更小、更易于管理的大小,以便通過文件傳輸進行共享。XZ-Utils 是Linux、Unix 等POSIX 兼容系統中廣泛用于處理.xz文件的套件,包含liblzma、xz 等組件,已集成在debian、ubuntu、centos 等發行版倉庫中。


              漏洞編號

              • CVE-2024-3094


              漏洞類型

              • 惡意后門植入漏洞


              漏洞等級

              • 極危


              漏洞狀態

              image.png

              受影響版本

              •  xz-utils@[5.6.0, 5.6.1]


              修復建議

              目前,請立即停止使用 Fedora 41 或 Fedora Rawhide ,以及相關測試版Debian,使用了受影響版本的XZ Util ,建議降級至 5.6.0 以下版本,或在應用中替換為7zip等組件。

              https://www.redhat.com/en/blog/urgent-security-alert-fedora-41-and-rawhide-users


              參考鏈接

              • https://www.oscs1024.com/hd/MPS-03mz-nh7f

              • https://www.openwall.com/lists/oss-security/2024/03/29/4

              • https://nvd.nist.gov/vuln/detail/CVE-2024-3094

              • https://salsa.debian.org/debian/xz-utils/-/blob/debian/unstable/m4/build-to-host.m4?ref_type=heads#L63

              • https://www.redhat.com/en/blog/urgent-security-alert-fedora-41-and-rawhide-users

              • https://avd.aliyun.com/detail?id=AVD-2024-3094

              • https://ti.qianxin.com/vulnerability/notice-detail/916


              分享到微信
              X
              一念关山原著小说 亲亲小说 免费小说在线观看 性虐小说